Instagram Historical Metrics Gap

Incident Report for Emplifi

Resolved

Issue has been resolved and data rebuilds are completed.
Thank you for your patience.
Posted Jun 09, 2025 - 10:20 UTC

Identified

The issue has been identified and fix is being implemented.
Posted Jun 06, 2025 - 07:44 UTC

Investigating

- Many Instagram profiles have lost Media Views and Impressions data before 2 June 2025.
- Demography metrics are missing before 2 June 2025; some profiles show data only from 3 June 2025.
We are investigating the cause across relevant Emplifi products to restore the missing data and prevent further issues.
Posted Jun 04, 2025 - 10:17 UTC
This incident affected: Suite (Dashboard, Content Hub, Unified Analytics).