It's not possible to connect Facebook & Instagram Ad Accounts
Incident Report for Socialbakers
Resolved
This incident has been resolved.
Posted Sep 12, 2019 - 06:42 UTC
Identified
Our developers are onto it! This issue should be fixed on Thu, 12 Sep 2019 around 9:00 CET.
Posted Sep 11, 2019 - 14:59 UTC
This incident affected: Suite.