Performance issues during loading parts of Suite
Incident Report for Socialbakers
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 20, 2017 - 16:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Jun 20, 2017 - 15:38 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Jun 20, 2017 - 14:03 UTC