Missing Instagram data - Media views

Incident Report for Emplifi

Resolved

Status: Resolved

The issue impacting Instagram media views metrics has been fully resolved. Meta deployed a fix, and all affected data have now been successfully backfilled and verified across Emplifi analytics products.

Incident Details:
This incident affected Instagram media views metrics for some posts starting on October 29, 2025. The issue originated from missing data in Meta’s API response, which also impacted related metrics such as impressions and video views.

Resolution:
Meta has fixed the underlying issue, and Emplifi has completed verification and backfill of all missing data.

If you still notice any discrepancies in your Instagram analytics, please contact the Emplifi Support Team for assistance.
Posted Nov 07, 2025 - 12:33 UTC

Monitoring

Status: Monitoring

Meta has deployed a fix for the issue affecting Instagram media views metrics. We are currently verifying the resolution on our side and backfilling the missing data across Emplifi analytics products.

Incident Details:
The disruption affected Instagram media views metrics for some posts, starting on October 29, 2025. The media views metric was missing for certain posts, impacting related metrics such as impressions and video views. The issue was caused by missing values in Meta’s API response.

Current Actions:
We are monitoring the fix implementation and verifying data integrity. The backfill process for missing metrics is in progress. We will provide a final update once the fix is confirmed and all data has been restored.
Posted Nov 07, 2025 - 10:51 UTC

Identified

Status: Identified
We have identified the cause of the disruption in Instagram data across Emplifi analytics products. Meta has confirmed that the issue is on their side and is actively working on a fix.

Incident Details:
We have identified an issue affecting Instagram media views metrics for some posts, as of 29th October 2025.
The media views metric is completely missing for certain posts. All related metrics based on media views — such as impressions, video views, etc. — are also impacted. Our investigation indicates that this is a Meta (Instagram) API issue, as the views metric value is missing from their API response.

Current Actions:
Meta has acknowledged the bug, and their engineering team is actively working to resolve it.
We will continue to monitor the situation closely and provide updates as soon as we have additional information or an ETA for the fix.
Posted Nov 04, 2025 - 09:37 UTC
This incident affected: Suite (Dashboard, Content Hub, Unified Analytics) and API.