Performance issues
Incident Report for Socialbakers
Resolved
This incident has been resolved.
Posted 7 days ago. Aug 08, 2018 - 08:30 UTC
Investigating
We are currently investigating this issue.
Posted 8 days ago. Aug 07, 2018 - 15:00 UTC
This incident affected: Suite.