Meta Service Disruption - Facebook and Instagram outage
Incident Report for Emplifi
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 18:07 UTC
Identified
Meta is currently experiencing a service disruption impacting Facebook, Instagram, and Messenger. Multiple services are unavailable.
Posted Mar 05, 2024 - 16:24 UTC
This incident affected: Suite.