Products not working
Incident Report for Socialbakers
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 11, 2017 - 15:08 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Apr 11, 2017 - 14:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Apr 11, 2017 - 14:57 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Apr 11, 2017 - 14:23 UTC