Missing Instagram data - Media views

Incident Report for Emplifi

Update

We are continuing to monitor for any further issues.
Posted Jul 29, 2025 - 02:05 UTC

Update

Status: Data Rebuilds In Progress

Update:
As part of the recovery from the Meta API issue, data rebuilds are currently in progress to restore Instagram media views and all related metrics for affected posts.

The rebuild process is expected to be completed by Thursday, 31st July 2025.

If your profile is still impacted and you require your data to be rebuilt sooner, please contact our Support Team to request an immediate rebuild.

We will provide a final update once the global rebuild is complete.

Thank you for your continued cooperation and patience.

— The Emplifi Team
Posted Jul 28, 2025 - 13:22 UTC

Update

Status: Data Rebuilds Scheduled

Update:
Following the resolution of the Meta API issue, we have completed an initial round of data validation.

This validation has confirmed the need for additional data rebuilds to fully restore accuracy for Instagram media views and related metrics.

We have scheduled these data rebuilds to run over the next 6 days. Affected metrics will be progressively updated during this period.

We will provide a final update once the rebuild process is complete.

Thank you for your continued patience and understanding.

— The Emplifi Team
Posted Jul 25, 2025 - 08:06 UTC

Monitoring

Status: Resolved — Monitoring & Data Validation in Progress

Update:
Meta has resolved the issue affecting Instagram media views and related metrics. The views metric is now being returned correctly via the API.

We are currently:
Monitoring the stability of the fix and validating impacted data across affected posts

Thank you for your patience throughout this incident.

— The Emplifi Team
Posted Jul 24, 2025 - 10:01 UTC

Identified

Status: Fix Deployed by Meta — Monitoring & Backfill Planned

Update:
Meta has confirmed this was a widespread issue on their side.
They have deployed a fix a few hours ago, and the issue should resolve within the next 1–2 days.

We will be monitoring the fix closely to ensure it is fully resolved. Once Meta’s fix is confirmed, we will also prepare and execute a data backfill to recover the missing Instagram media views and related metrics for affected posts.

We’ll continue to keep you updated as we monitor the resolution and proceed with the backfill.

Thank you for your continued patience.

— The Emplifi Team
Posted Jul 23, 2025 - 10:59 UTC

Update

Status: Investigation in Progress
Impact: Clients may see missing Instagram media views and related metrics — such as impressions, video views, etc. — for some posts.

Update:
The root cause of this issue is an API owned by Meta. As previously mentioned, we have escalated the issue to Meta and they have confirmed that they are actively investigating the problem on their side.

We continue to monitor their progress and will share further updates as soon as we receive more information from Meta.
Posted Jul 21, 2025 - 17:48 UTC

Update

Status: Investigation in Progress
Impact: Clients may see missing Instagram media views and related metrics — such as impressions, video views, etc. — for some posts.

Update:
We have escalated the issue to Meta, and they have confirmed that they are actively investigating the problem on their side.

We will continue to monitor their progress and share further updates as soon as we receive more information from Meta.

Thank you for your continued patience while this is being resolved.

— The Emplifi Team
Posted Jul 17, 2025 - 07:29 UTC

Investigating

We are experiencing a disruption in Instagram data across Emplifi analytics products, due to a Meta bug.
We will provide updates as soon as we have more information from the Third Party.

Incident Details:
We have identified an issue affecting Instagram media views metrics for some posts.
The media views metric is completely missing for certain posts.
All related metrics based on media views — such as impressions, video views, etc. — are also impacted.

Our investigation indicates that this is a Meta (Instagram) API issue, as the views metric value is missing from their API response.


Current Actions:
We have opened a bug ticket with Meta and are awaiting their response.
We are monitoring the situation closely and will provide updates as soon as we have more information from Meta.
Posted Jul 16, 2025 - 09:09 UTC
This incident affects: Suite (Dashboard, Content Hub, Unified Analytics) and API.