Platform Degradation

Incident Report for Emplifi

Resolved

Our team has successfully identified and addressed the root cause of the incident, and all services have been fully restored. A detailed incident report will be available by early next week.
Posted May 24, 2025 - 17:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 24, 2025 - 17:01 UTC

Investigating

We are investigating an issue with loading of Emplifi Suite. We are working to resolve the issue as quickly as possible.
Posted May 24, 2025 - 16:44 UTC
This incident affected: Suite.